Back
Maintenance

Server Maintenance

Completed 21 Feb at 01:30am EST.

New Jersey
Completed

Maintenance completed

Posted 21 Feb at 01:30am EST.
Started

We will be performing a backend upgrade on our servers located in our NJ datacenter. During this maintenance window we expect around 5-15 minutes of downtime.

Posted 21 Feb at 01:00am EST.